Twitter Facebook Google Plus Linked in

Compatibility with macOS 10.13 - High Sierra

This article provides information about the compatibility of LaCie hardware and software with macOS 10.13 High Sierra. 

 

This article provides information about the compatibility of LaCie hardware and software with macOS 10.13 High Sierra.

As with every major new operating system update or release, LaCie evaluates current products to determine their compatibility with a new operating system. Please see the below compatibility information for LaCie hardware and software.


Hardware:

Current Products, which LaCie considers USB 3.0, USB 3.1 and/or Thunderbolt capable, are listed in the following table. Older drives that are not listed in this table may work, but have not been tested.

 
ProductHardware
Rugged FamilyYes
d2 FamilyYes
big Family*Yes
RackmountYes
Porsche FamilyYes
Limited Edition/Extreme ProductsYes
FuelYes with latest firmware
Portable DriveYes


*Important: 5big and 8big Thunderbolt 2 products require the latest RAID firmware. if LaCie RAID Manager isn't detecting your device, please follow the instructions here to update your firmware. 
 

Note: If a pop-up blocker is installed, you may need to disable it in order to access the links. Or you can press the Command key and click on the link to open it in a new tab.


Software:

Certain applications require an update for proper function with macOS 10.13. Detailed information about each software can be found in its respective support page.

The following lists which LaCie software applications are compatible with macOS 10.13:
 

SoftwareVersionRequirements
 

2.5.704.24245

Enabling Security Settings may be required. See instructions here.

LaCie Desktop Manager

2.9.1

Enabling Security Settings may be required. See instructions here.

LaCie Setup Assistant

3.1
Some LaCie products that still available for sale might not feature the latest version of LSA. For further assistance with LaCie Setup Assistant, please see here.

LaCie Private-Public

1.9.5

Enabling Security Settings may be required. See instructions here.

Network Assistant

Untested

No, the software was not updated.

Intego Backup Assistant

2

Enabling Security Settings may be required. See instructions here.

Intego Backup Manager Pro

2.1

Enabling Security Settings may be required. See instructions here.


If during the software installation you received an alert message “System Extension Blocked”, please click here.